習題2.2:B. Radar Installation

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

題意:

??假設海岸線是一條無限延伸的直線。陸地在海岸線的一側,而海洋在另一側。每一個小的島嶼是海洋上的一個點。雷達坐落于海岸線上,只能覆蓋d距離,所以如果小島能夠被覆蓋到的話,它們之間的距離最多為d。題目要求計算出能夠覆蓋給出的所有島嶼的最少雷達數目。

解題思路:

??我們假設島嶼i它的x坐標為island[i][0],而y坐標為island[i][1],那么有以下幾種情況是invalide的,即輸出-1的情況:
1.island[i][1]<0
2.abs(island[i][1])>d
3.d<0
其他的情況,應該就是正常情況,進入計算最小雷達數目。


image.png

如上圖,紅色的點為島嶼,那么能夠覆蓋到此島嶼的雷達所在的區間,應該就是以該島嶼為圓心的圓與x軸交點所在的區間。

這樣,我們就可以計算出所有島嶼的雷達所在的區間,得到一個區間數組。

我們將這個數組按照區間左部分進行排序,那么重疊部分就表明這些島嶼的雷達可以共用一個。從而計算出最終解。

可以把所有的島的坐標通過x(+ -)sqrt(d*d-y*y)得出可以掃射到它的雷達的區域范圍,在對右坐標進行排序。

但是千萬不要忘記還有右坐標相等的情況,這種時候你知道肯定要選區間小的范圍(一定可以掃射到區間范圍大的島),即讓左坐標大的排在前面。

拍完序后,你就要用到貪心法,每次都貪心的選擇最右端的點作為判斷點,循環到最后,可以得出最少的雷達數。

#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
#define MAX 1005
using namespace std;
struct note{
    double left,right;
}b[MAX];
bool cmp(note a,note b)      //結構體排序
{
    if(a.right==b.right) return a.left>b.left; 
        else
    return a.right<b.right;
}
int acount,n; 
void search(double maxn)      //找到最少的雷達數
{
    int i;
    for(i=1;i<n;i++)
        if(b[i].left>maxn)
        {
            maxn=b[i].right;        //都取最右端
            acount++;
        }
}
int main()
{
    double d,x,y;
    scanf("%d%lf",&n,&d);
    int t=0;
    while(n||d)
    {
        t++;
        int o=0;
        acount=0;
        for(int i=0;i<n;i++)
        {
            scanf("%lf%lf",&x,&y);
            if(y>d)                      //判斷是否可以掃射到島
                o++;
            b[i].left=x-sqrt((d*d)-(y*y));         //預處理,變成區間
            b[i].right=x+sqrt((d*d)-(y*y));
        }
        if(!o)
        {
            sort(b,b+n,cmp);
            search(b[0].right);
            printf("Case %d: %d\n",t,acount+1);
        }
        else
            printf("Case %d: -1\n",t);
        scanf("%d%lf",&n,&d);
    }
    return 0;
}
最后編輯于
?著作權歸作者所有,轉載或內容合作請聯系作者
  • 序言:七十年代末,一起剝皮案震驚了整個濱河市,隨后出現的幾起案子,更是在濱河造成了極大的恐慌,老刑警劉巖,帶你破解...
    沈念sama閱讀 227,488評論 6 531
  • 序言:濱河連續發生了三起死亡事件,死亡現場離奇詭異,居然都是意外死亡,警方通過查閱死者的電腦和手機,發現死者居然都...
    沈念sama閱讀 98,034評論 3 414
  • 文/潘曉璐 我一進店門,熙熙樓的掌柜王于貴愁眉苦臉地迎上來,“玉大人,你說我怎么就攤上這事。” “怎么了?”我有些...
    開封第一講書人閱讀 175,327評論 0 373
  • 文/不壞的土叔 我叫張陵,是天一觀的道長。 經常有香客問我,道長,這世上最難降的妖魔是什么? 我笑而不...
    開封第一講書人閱讀 62,554評論 1 307
  • 正文 為了忘掉前任,我火速辦了婚禮,結果婚禮上,老公的妹妹穿的比我還像新娘。我一直安慰自己,他們只是感情好,可當我...
    茶點故事閱讀 71,337評論 6 404
  • 文/花漫 我一把揭開白布。 她就那樣靜靜地躺著,像睡著了一般。 火紅的嫁衣襯著肌膚如雪。 梳的紋絲不亂的頭發上,一...
    開封第一講書人閱讀 54,883評論 1 321
  • 那天,我揣著相機與錄音,去河邊找鬼。 笑死,一個胖子當著我的面吹牛,可吹牛的內容都是我干的。 我是一名探鬼主播,決...
    沈念sama閱讀 42,975評論 3 439
  • 文/蒼蘭香墨 我猛地睜開眼,長吁一口氣:“原來是場噩夢啊……” “哼!你這毒婦竟也來了?” 一聲冷哼從身側響起,我...
    開封第一講書人閱讀 42,114評論 0 286
  • 序言:老撾萬榮一對情侶失蹤,失蹤者是張志新(化名)和其女友劉穎,沒想到半個月后,有當地人在樹林里發現了一具尸體,經...
    沈念sama閱讀 48,625評論 1 332
  • 正文 獨居荒郊野嶺守林人離奇死亡,尸身上長有42處帶血的膿包…… 初始之章·張勛 以下內容為張勛視角 年9月15日...
    茶點故事閱讀 40,555評論 3 354
  • 正文 我和宋清朗相戀三年,在試婚紗的時候發現自己被綠了。 大學時的朋友給我發了我未婚夫和他白月光在一起吃飯的照片。...
    茶點故事閱讀 42,737評論 1 369
  • 序言:一個原本活蹦亂跳的男人離奇死亡,死狀恐怖,靈堂內的尸體忽然破棺而出,到底是詐尸還是另有隱情,我是刑警寧澤,帶...
    沈念sama閱讀 38,244評論 5 355
  • 正文 年R本政府宣布,位于F島的核電站,受9級特大地震影響,放射性物質發生泄漏。R本人自食惡果不足惜,卻給世界環境...
    茶點故事閱讀 43,973評論 3 345
  • 文/蒙蒙 一、第九天 我趴在偏房一處隱蔽的房頂上張望。 院中可真熱鬧,春花似錦、人聲如沸。這莊子的主人今日做“春日...
    開封第一講書人閱讀 34,362評論 0 25
  • 文/蒼蘭香墨 我抬頭看了看天上的太陽。三九已至,卻和暖如春,著一層夾襖步出監牢的瞬間,已是汗流浹背。 一陣腳步聲響...
    開封第一講書人閱讀 35,615評論 1 280
  • 我被黑心中介騙來泰國打工, 沒想到剛下飛機就差點兒被人妖公主榨干…… 1. 我叫王不留,地道東北人。 一個月前我還...
    沈念sama閱讀 51,343評論 3 390
  • 正文 我出身青樓,卻偏偏與公主長得像,于是被迫代替她去往敵國和親。 傳聞我的和親對象是個殘疾皇子,可洞房花燭夜當晚...
    茶點故事閱讀 47,699評論 2 370