Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
1 2
-3 1
2 11 2
0 20 0
Sample Output
Case 1: 2
Case 2: 1
題意:
??假設海岸線是一條無限延伸的直線。陸地在海岸線的一側,而海洋在另一側。每一個小的島嶼是海洋上的一個點。雷達坐落于海岸線上,只能覆蓋d距離,所以如果小島能夠被覆蓋到的話,它們之間的距離最多為d。題目要求計算出能夠覆蓋給出的所有島嶼的最少雷達數目。
解題思路:
??我們假設島嶼i它的x坐標為island[i][0],而y坐標為island[i][1],那么有以下幾種情況是invalide的,即輸出-1的情況:
1.island[i][1]<0
2.abs(island[i][1])>d
3.d<0
其他的情況,應該就是正常情況,進入計算最小雷達數目。
如上圖,紅色的點為島嶼,那么能夠覆蓋到此島嶼的雷達所在的區間,應該就是以該島嶼為圓心的圓與x軸交點所在的區間。
這樣,我們就可以計算出所有島嶼的雷達所在的區間,得到一個區間數組。
我們將這個數組按照區間左部分進行排序,那么重疊部分就表明這些島嶼的雷達可以共用一個。從而計算出最終解。
可以把所有的島的坐標通過x(+ -)sqrt(d*d-y*y)得出可以掃射到它的雷達的區域范圍,在對右坐標進行排序。
但是千萬不要忘記還有右坐標相等的情況,這種時候你知道肯定要選區間小的范圍(一定可以掃射到區間范圍大的島),即讓左坐標大的排在前面。
拍完序后,你就要用到貪心法,每次都貪心的選擇最右端的點作為判斷點,循環到最后,可以得出最少的雷達數。
#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
#define MAX 1005
using namespace std;
struct note{
double left,right;
}b[MAX];
bool cmp(note a,note b) //結構體排序
{
if(a.right==b.right) return a.left>b.left;
else
return a.right<b.right;
}
int acount,n;
void search(double maxn) //找到最少的雷達數
{
int i;
for(i=1;i<n;i++)
if(b[i].left>maxn)
{
maxn=b[i].right; //都取最右端
acount++;
}
}
int main()
{
double d,x,y;
scanf("%d%lf",&n,&d);
int t=0;
while(n||d)
{
t++;
int o=0;
acount=0;
for(int i=0;i<n;i++)
{
scanf("%lf%lf",&x,&y);
if(y>d) //判斷是否可以掃射到島
o++;
b[i].left=x-sqrt((d*d)-(y*y)); //預處理,變成區間
b[i].right=x+sqrt((d*d)-(y*y));
}
if(!o)
{
sort(b,b+n,cmp);
search(b[0].right);
printf("Case %d: %d\n",t,acount+1);
}
else
printf("Case %d: -1\n",t);
scanf("%d%lf",&n,&d);
}
return 0;
}