Description
A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.
To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).
The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).
Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.
Input
Line 1: A single integer, N
Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.
Line N+2: Two space-separated integers, L and P
Output
- Line 1: A single integer giving the minimum number of fuel stops necessary to >reach the town. If it is not possible to reach the town, output -1.
Sample Input
4
4 4
5 2
11 5
15 10
25 10
Sample Output
2
Hint
INPUT DETAILS:
The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.
OUTPUT DETAILS:
Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.
題意:
??題目意思是一輛卡車距離城鎮有L距離,車中還有P油量,每向前行駛一單位距離消耗一單位的油量,如果在途中卡車中就沒有油了 ,就無法到達終點;途中有N個加油站,加油站提供的油量有限,卡車的油箱是無限的,給出每個加油站距離終點的距離和提供的油量,問卡車在途中最少需要加幾次油。
解題思路:
??采用貪心的思想,卡車當然在不加油的情況下走的越遠越好了,而當它沒油時,我們再判斷卡車在經過的途中的加油站,哪個加油站加的油最多,選油量最多的,這樣后面加油次數也越少,然后又繼續行駛,當它又沒油了的時候,繼續選它從起點到該點所經過的加油站油量最多的加油。
??做法先將加油站到終點的距離由遠到近排下序,這樣離起點就是由近到遠。就是每經過一個加油站就將該加油站的油量壓入優先隊列中,然后每次沒油的時候,去隊首元素加油即可。
?在經過加油站i時,往優先隊列里加入Bi。
?當燃料箱空了時,
??如果優先隊列也是空的,則無法到達終點。
??否則取出優先隊列中的最大元素,并喲過來給卡車加油。
題解:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include <queue>
using namespace std;
#define MAX 10001
//定義每個加油站的結構體
struct node
{
int dis,flue;
}stop[MAX];
//將每個加油站按距出發點的距離由小到大排序
bool cmp(node a,node b)
{
return a.dis>b.dis;
}
int main()
{
int N,L,P;
while(cin>>N)
{
//輸入
for(int n=0;n<N;n++)
cin >> stop[n].dis >> stop[n].flue;
cin >> L >> P;
//將終點視作dis=0,flue=0的加油站
stop[N].dis = 0;
stop[N].flue = 0;
sort(stop,stop+N,cmp);
N++;
//維護優先隊列
priority_queue<int> que;
//ans: 加油次數,pos:當前位置,tank:剩余油量
int ans = 0,pos = L,tank = P;
//i是下個加油站的索引
for(int i=0;i<N;i++)
{
//接下來要前進的距離
int d = pos - stop[i].dis;
//不斷加油直到油量足夠行駛到下一個加油站
while(tank-d<0)
{
//如果油箱空了
if(que.empty())
{
puts("-1");
return 0;
}
//否則
tank += que.top();
que.pop();
ans++;
}
tank -= d;
pos = stop[i].dis;
que.push(stop[i].flue);
}
cout << ans << endl;
}
}