課程:F. Expedition

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

Input

  • Line 1: A single integer, N

  • Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

  • Line N+2: Two space-separated integers, L and P

Output

  • Line 1: A single integer giving the minimum number of fuel stops necessary to >reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

題意:

??題目意思是一輛卡車距離城鎮有L距離,車中還有P油量,每向前行駛一單位距離消耗一單位的油量,如果在途中卡車中就沒有油了 ,就無法到達終點;途中有N個加油站,加油站提供的油量有限,卡車的油箱是無限的,給出每個加油站距離終點的距離和提供的油量,問卡車在途中最少需要加幾次油。

解題思路:

??采用貪心的思想,卡車當然在不加油的情況下走的越遠越好了,而當它沒油時,我們再判斷卡車在經過的途中的加油站,哪個加油站加的油最多,選油量最多的,這樣后面加油次數也越少,然后又繼續行駛,當它又沒油了的時候,繼續選它從起點到該點所經過的加油站油量最多的加油。
??做法先將加油站到終點的距離由遠到近排下序,這樣離起點就是由近到遠。就是每經過一個加油站就將該加油站的油量壓入優先隊列中,然后每次沒油的時候,去隊首元素加油即可。
?在經過加油站i時,往優先隊列里加入Bi。
?當燃料箱空了時,
??如果優先隊列也是空的,則無法到達終點。
??否則取出優先隊列中的最大元素,并喲過來給卡車加油。

題解:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include <queue>
using namespace std;
#define MAX 10001
//定義每個加油站的結構體 
struct node            
{
    int dis,flue;
}stop[MAX];
//將每個加油站按距出發點的距離由小到大排序 
bool cmp(node a,node b)     
{
    return a.dis>b.dis;
}
int main()
{
    int N,L,P;
    while(cin>>N)
    {
        //輸入
        for(int n=0;n<N;n++)
            cin >> stop[n].dis >> stop[n].flue;         
        cin >> L >> P;
        //將終點視作dis=0,flue=0的加油站 
        stop[N].dis = 0;
        stop[N].flue = 0;
        sort(stop,stop+N,cmp);
        N++;
        //維護優先隊列 
        priority_queue<int> que;
        //ans: 加油次數,pos:當前位置,tank:剩余油量 
        int ans = 0,pos = L,tank = P;
        //i是下個加油站的索引 
        for(int i=0;i<N;i++)
        {
            //接下來要前進的距離
            int d =  pos - stop[i].dis;
            //不斷加油直到油量足夠行駛到下一個加油站
            while(tank-d<0)
            {
                //如果油箱空了 
                if(que.empty())
                {
                    puts("-1");
                    return 0;
                }
                //否則 
                tank += que.top();
                que.pop();
                ans++;
            }
            tank -= d;
            pos = stop[i].dis;
            que.push(stop[i].flue);
        }
        cout << ans << endl;
    }
}
最后編輯于
?著作權歸作者所有,轉載或內容合作請聯系作者
  • 序言:七十年代末,一起剝皮案震驚了整個濱河市,隨后出現的幾起案子,更是在濱河造成了極大的恐慌,老刑警劉巖,帶你破解...
    沈念sama閱讀 227,488評論 6 531
  • 序言:濱河連續發生了三起死亡事件,死亡現場離奇詭異,居然都是意外死亡,警方通過查閱死者的電腦和手機,發現死者居然都...
    沈念sama閱讀 98,034評論 3 414
  • 文/潘曉璐 我一進店門,熙熙樓的掌柜王于貴愁眉苦臉地迎上來,“玉大人,你說我怎么就攤上這事?!?“怎么了?”我有些...
    開封第一講書人閱讀 175,327評論 0 373
  • 文/不壞的土叔 我叫張陵,是天一觀的道長。 經常有香客問我,道長,這世上最難降的妖魔是什么? 我笑而不...
    開封第一講書人閱讀 62,554評論 1 307
  • 正文 為了忘掉前任,我火速辦了婚禮,結果婚禮上,老公的妹妹穿的比我還像新娘。我一直安慰自己,他們只是感情好,可當我...
    茶點故事閱讀 71,337評論 6 404
  • 文/花漫 我一把揭開白布。 她就那樣靜靜地躺著,像睡著了一般。 火紅的嫁衣襯著肌膚如雪。 梳的紋絲不亂的頭發上,一...
    開封第一講書人閱讀 54,883評論 1 321
  • 那天,我揣著相機與錄音,去河邊找鬼。 笑死,一個胖子當著我的面吹牛,可吹牛的內容都是我干的。 我是一名探鬼主播,決...
    沈念sama閱讀 42,975評論 3 439
  • 文/蒼蘭香墨 我猛地睜開眼,長吁一口氣:“原來是場噩夢啊……” “哼!你這毒婦竟也來了?” 一聲冷哼從身側響起,我...
    開封第一講書人閱讀 42,114評論 0 286
  • 序言:老撾萬榮一對情侶失蹤,失蹤者是張志新(化名)和其女友劉穎,沒想到半個月后,有當地人在樹林里發現了一具尸體,經...
    沈念sama閱讀 48,625評論 1 332
  • 正文 獨居荒郊野嶺守林人離奇死亡,尸身上長有42處帶血的膿包…… 初始之章·張勛 以下內容為張勛視角 年9月15日...
    茶點故事閱讀 40,555評論 3 354
  • 正文 我和宋清朗相戀三年,在試婚紗的時候發現自己被綠了。 大學時的朋友給我發了我未婚夫和他白月光在一起吃飯的照片。...
    茶點故事閱讀 42,737評論 1 369
  • 序言:一個原本活蹦亂跳的男人離奇死亡,死狀恐怖,靈堂內的尸體忽然破棺而出,到底是詐尸還是另有隱情,我是刑警寧澤,帶...
    沈念sama閱讀 38,244評論 5 355
  • 正文 年R本政府宣布,位于F島的核電站,受9級特大地震影響,放射性物質發生泄漏。R本人自食惡果不足惜,卻給世界環境...
    茶點故事閱讀 43,973評論 3 345
  • 文/蒙蒙 一、第九天 我趴在偏房一處隱蔽的房頂上張望。 院中可真熱鬧,春花似錦、人聲如沸。這莊子的主人今日做“春日...
    開封第一講書人閱讀 34,362評論 0 25
  • 文/蒼蘭香墨 我抬頭看了看天上的太陽。三九已至,卻和暖如春,著一層夾襖步出監牢的瞬間,已是汗流浹背。 一陣腳步聲響...
    開封第一講書人閱讀 35,615評論 1 280
  • 我被黑心中介騙來泰國打工, 沒想到剛下飛機就差點兒被人妖公主榨干…… 1. 我叫王不留,地道東北人。 一個月前我還...
    沈念sama閱讀 51,343評論 3 390
  • 正文 我出身青樓,卻偏偏與公主長得像,于是被迫代替她去往敵國和親。 傳聞我的和親對象是個殘疾皇子,可洞房花燭夜當晚...
    茶點故事閱讀 47,699評論 2 370

推薦閱讀更多精彩內容